バージョンアップでハマる

 昨日の晩はさくさくと似非GTSについてまとめたあと、久々にチャットのCGIをバージョンアップする事に。どうやらファイル本体のみを更新すればいいらしく、中に書き込まれている設定部分をそのまま移した…つもりが全然動かない。フレームで分けられている上部がInternal Server Errorになってしまいます。

 延々調べていると、どうやら内部でrequireでもって外部ライブラリを呼び出している部分がコメントになっていたらしく、そのコメントを外すとエラーは出なくなった…のですが、その外部ライブラリが動作しない。いろいろ設定を変えても駄目で、その外部ライブラリを上書きアップロードした所、今度はそのCGIへリンクしたら、CGI自体を単なるファイルと見なして「どのフォルダに保存しますか?」てなダイアログが出てきたので急いで元に戻したりして。結局その外部ライブラリから呼び出している外部ライブラリ(ややこしい(^^;)へのパスが間違っていて、呼び出しに失敗していたのを発見。

 まぁ、これで元に戻ったので、新たな原因を探ろうと、データファイルを上書きアップロードしても変化無し。他の原因もいろいろ試してみたんだけど駄目で、ふとデータファイルの名前を見ると拡張子がdat。これじゃあバイナリーでアップされてるかもと思い、アスキー形式で再アップすると、これが正解、きちんと動作するようになりました。

 そういえば以前バージョンアップした時も結構苦労した覚えがあるし、やっぱり難しいです。設定の部分だけ外部ファイルになっているとか、そういう形式だとラクチンなのですが。

スポンサーリンク
レクタングル(大)広告
レクタングル(大)広告