慣れると失敗してしまう

 昨日書いた更新延期になったCGIが何とかリリースされていたので、早速アップグレード。CGIをいくつも設置してきたし、いつも最新バージョンを使いたい私はアップグレードも数多くやってきたので、さくさくと必要な設定を変更。早速、念のために予備に設置している方で試してみたのですが、なんと上手く動きません

 今回のバージョンアップではファイル形式の変更や機能追加などがかなり多かったので、その辺りで何かエラーが出ているのかな~と思って色々調べたり、perlのバージョンをチェックしても問題なし。これはサポート掲示板にて助けを求めるしかないかな~と思っていた時に、ふと気づきました。

 こののCGIでは、直接的に指定して(リンク等)使うCGIファイルの他に、そのファイルからライブラリとして呼び出すCGIファイルがあるのですが、そちらをアップグレードするのを忘れていたんです。そりゃぁ動かない訳だわと、早速それらのファイルも更新すると、何事もなかったかの様にきちんと動くようになりました。何とも格好悪いミスで(^^;。

スポンサーリンク
レクタングル(大)広告
レクタングル(大)広告